CUPERTINO

Ce tutoriel vous guidera, pas à pas dans la configuration de CUPERTINO. Vous pourrez alors échanger des fichiers entre votre ordinateur et votre site sur Pharouest.

1 - Téléchargez CUPERTINO
Si vous ne l'avez pas encore fait, téléchargez CUPERTINO et installez-le sur votre ordinateur.
Ce logiciel est en version freeware (license gratuite).
Il est à noter que l'installation est simple. En effet le fichier téléchargé est un fichier compressé (cupertino.zip) qu'il suffit de décompresser pour pouvoir utiliser le logiciel. Après décompression vous obtenez le fichier cupertino.exe que vous enregistrez où vous le souhaitez sur votre disque dur.

2 - Ouvrez une session sur CUPERTINO.
La première fois que vous allez lancer CUPERTINO, la connexion FTP sur votre site Pharouest n'est pas encore paramétrée, il faut donc le faire. Pour cela allez dans le menu "File" comme ci-dessous :

Ensuite vous saisirez les informations de connexion dans la fenêtre de paramétrage. Vous remarquerez que le champ Password est resté à blanc. En effet il vaut mieux, pour une raison de sécurité (par exemple si vous n'êtes pas seul à utiliser le pc où est paramétrée la connexion), ne pas enregistrer le mot de passe, dans ce cas là il sera demandé à chaque connexion :

  Label : désignation du site distant
  Host Address : nom du serveur FTP (ici : pharouest.ac-rennes.fr)
  User ID : votre nom d'utilisateur Pharouest (ici celui de votre compte pharouest, ex : eXXXXXXX).
  Password : votre Mot de passe (ici celui de votre compte Pharouest).

Vous retrouvez toutes ces informations sur le courrier qui vous a été envoyé.

Le nom d'utilisateur et le mot de passe de connection sont sensibles à la casse, recpectez bien les minuscules et majuscules.

Après avoir validé, vous voyez apparaître votre site dans l'écran de CUPERTINO, mais comme on le voit dans la partie droite (Disconnected) vous n'êtes pas encore connecté :

 

3 - Connexion et Publication des fichiers
Pour vous connecter, il suffit soit de cliquer sur le + à coté de l'icône, soit de double-cliquer sur l'icône. Vous obtenez alors la connexion comme ci-dessous, et sur l'écran de droite vous visualisez les fichiers enregistrés à la racine de votre espace de publication sur le serveur Pharouest (les dossiers "bin" et "lib" ne devront jamais être supprimés) :

Maintenant que votre connexion est paramétrée, vous pouvez transférer vos fichiers sur le serveur Pharouest.
CUPERTINO fonctionne de la même manière que l'explorateur Windows :

L'écran gauche de l'interface
Ici se trouvent les lecteurs des différents disques durs (C:, D: etc...), lecteurs disquettes (A:) et CD (E:), ainsi que les sites distants (exemple : "Mon site sur Pharouest").

L'écran droit de l'interface
On visualise ce que contiennent les dossiers (exemple ici : "c:\pharouest\eXXXXXXX").
A partir de là, comme dans l'explorateur Windows, vous pouvez faire des copies de fichiers d'un lecteur vers un autre. Etant donné que l'on veut faire du transfert de fichier, on copiera ici les fichiers d'un lecteur local (ex : "c:\pharouest\eXXXXXXX") vers un site distant (ex : "Mon site sur Pharouest").
Pour cela vous pouvez utilisez les méthodes traditionnellement utilisées sous Windows après sélection d'un fichier :

  • En passant par le menu "Edit", et en choisissant l'action "Copy" (copier), ou "Paste" (coller) suivant ce que vous voulez faire.

  • En faisant un "CTRL + C" (copier), ou "CTRL + V" (coller)

  • En effectuant un click droit, et en choisissant dans le menu contextuel l'action "Copy" (copier), ou "Paste" (coller) suivant ce que vous voulez faire.

La partie basse de l'interface
Elle liste le détail des actions effectuées quand un fichier est transféré.

Astuces & suggestions
Dans la barre d'outils, vous pouvez voir trois boutons intitulés .
Pour de meilleures performances :

  • Les fichiers images tels que Gif et Jpeg devraient être transférés en mode binaire (Binary).
    Il est recommandé de transférer les documents Html en mode ASCII.
  • Pour éviter d'avoir à choisir fréquemment le type de transfert adéquat, vous pouvez simplement laisser l'option Auto activée en permanence.

4 - Achever votre session FTP
Pour vous déconnecter, passez par le menu "Tools" et cliquez sur "Disconnect", ou faites un click droit sur l'icône du site distant, et cliquuez sur "Disconnect" dans le menu contextuel.

5 - Consultez votre page
Pour visualiser et tester en ligne la ou les pages que vous venez de publier, saisissez son adresse URL dans votre navigateur :
http://pharouest.ac-rennes.fr/eXXXXXXX/sous_répertoire(s'il y a)/nom_fichier